Upstream vendor outage

Incident Report for Mastra Cloud

Resolved

The service disruption caused by our third party vendors has been fully resolved. All systems are operating normally with confirmed stability
Posted Jun 12, 2025 - 23:28 UTC

Monitoring

Our third-party vendors have restored their services and moved to monitoring phase to confirm sustained stability.
Posted Jun 12, 2025 - 21:12 UTC

Identified

We're seeing partial recovery from our third party vendors. Some of our services are now operational, though we're still experiencing issues with others.
Posted Jun 12, 2025 - 20:24 UTC

Investigating

We are currently experiencing significant service disruptions due to major outages affecting both Cloudflare and Google Cloud Platform (GCP)
Posted Jun 12, 2025 - 19:47 UTC
This incident affected: Dashboard, Builder, Platform API, Reporter, and Runner.